Permission error

Sep 2, 2008 at 11:20 AM
Hello,

First: Sorry for my english, i am french.

    Thanks for this template it's great, i have coded 4 webparts and installed them manually on the server (using the GAC and changing the webconfig file) but i am now asked to make something like a package for a cleaner work. So when i saw your work and saw it actually worked (after trying to do the solution manually without luck) i really appreciated it.
    Now the problem, 3 of my webparts use some connection to another server via webservice and such. It look like to need a full trust from the home server to work, i tried changing the .webpart file and adding "safe=True" but it didn't work i still have a permission error when i try to see the webpart in the webpart gallery.

Here is the error message i get :  "Fail of authorisation request from 'System.Net.WebPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'"
This is strange since i didn't sign the assembly for the solution so the webpart shouldn't have a PublicKeyToken right?

If anyone have advice it would be well pleased.