VMWare createwsp.bat error

Jul 17, 2008 at 12:18 PM
I tried the first demo and get an error on createwsp.bat

Error 1 The command "CD \\foo\bar$\MyDocuments\Visual Studio 2008\Projects\StevesFirstWebPart\StevesFirstWebPart\\WSP
createwsp.bat
    " exited with code 9009. StevesFirstWebPart

Info:
Running 2008 and MOSS2007 on a VMWare slice on Win2003.  The MyDocuments is set to another server "foo" where I have a folder "bar".  This is corporate policy and prbably cannot be changed.

When createing the project VS does see the template and opens normally.  When I click build...I get the error above.

Here is createwsp.bat

@ECHO OFF

ECHO Copying DLL ...

xcopy /y "..\bin\debug\StevesFirstWebPart.dll" .\80\BIN

ECHO Running WSPBuilder ...

.\WSPBuilder\wspbuilder -wspname StevesFirstWebPart.wsp -BuildCas false -SolutionId 7ca24c59-5b47-42c8-9495-ae0a9734dfdf

ECHO Copying WSP to Setup ...

xcopy /y "..\WSP\StevesFirstWebPart.wsp" ..\Setup

Aug 7, 2008 at 12:03 PM
Edited Aug 7, 2008 at 12:11 PM
I have a similar error but with another exit code:
Error 1 The command "CD C:\SPHOLS\Labs\Lab01_WebParts\SharePointWebPart1\SharePointWebPart1\\WSP
createwsp.bat
    " exited with code 4. SharePointWebPart1

In my case it is solved by replacing CABLIB.dll by x64 version
Nov 13, 2008 at 1:53 PM
Edited Nov 13, 2008 at 3:28 PM
Hi,

Sorry for asking the obvious, but where is that file located?

 - update: it's located in the download section